Failed to invoke startup class “JRF Startup Class” in OSB or SOA.

Hi guys!!!

After installation of soa-infra or osb, in the first time the the managed server starts, the error occurs:

####     <[ACTIVE] ExecuteThread: '0' for queue: 'weblo gic.kernel.Default (self-tuning)'> <> <> <> <1478002511204>  
at weblogic.management.deploy.classdeployment.ClassDeploymentManager.invokeClass(ClassDeploymentManager.java:274)
at weblogic.management.deploy.classdeployment.ClassDeploymentManager.access$000(ClassDeploymentManager.java:54)
at weblogic.management.deploy.classdeployment.ClassDeploymentManager$1.run(ClassDeploymentManager.java:226)
at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:120)
at weblogic.management.deploy.classdeployment.ClassDeploymentManager.invokeClassDeployment(ClassDeploymentManager.java:258)
at weblogic.management.deploy.classdeployment.ClassDeploymentManager.runStartupsBeforeAppDeployments(ClassDeploymentManager.java:149)
at weblogic.management.deploy.classdeployment.ClassDeploymentService.start(ClassDeploymentService.java:21)
at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)
at weblogic.work.ExecuteThread.execute(ExecuteThread.java:256)
at weblogic.work.ExecuteThread.run(ExecuteThread.java:221)

SOLUTION:
Just edit the nodemanager.properties file that is inside the $WL_HOME/common/nodemanager.
Find the line with the content “StartScriptEnabled=false” and replace to “StartScriptEnabled=true”

If do you prefer, just run the command:

sed -i ‘s/StartScriptEnabled=false/StartScriptEnabled=true/g’ $WL_HOME/common/nodemanager/nodemanager.properties

2 thoughts on “Failed to invoke startup class “JRF Startup Class” in OSB or SOA.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.